java.lang.UnsupportedClassVersionError: org/eclipse/jetty/maven/plugin/JettyRunMojo : Unsupported major.minor version 52.0

■ JDK version 1.7.0_45에서 Jetty version 9.3.7.v20160115으로 아래와 같이 jetty-maven-plugin을 pom.xml 파일에 등록하고 jetty:run을 실행하니 제목과 같은 에러가 발생했다. JDK version 1.7.0_45에서는 Jetty version을 9.2.10.v20150310으로 낮추어 설정하니 에러가 발생하지 않았다.

Jetty Version 9.3.7.v20160115는 JDK version 1.8.0_73에서 에러없이 정상적으로 실행되었다.

<build>
<plugins>

<plugin>
  <groupId> org.eclipse.jetty</groupId >
  <artifactId> jetty-maven-plugin</artifactId >
  <version>9.3.7.v20160115</version >
</plugin>

</plugins>
</build>

 

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다